Temporary Issue Downloading PDF Files
Minor incident
Reckon Accounts Hosted
27-Oct-25 11:02 AM AEDT
· 21 hours, 44 minutes
Updates
Resolved
October 28, 2025 · 08:44 AM AEDT
Resolved: PDF Download Issue in Chrome and Edge
We’ve resolved an issue that was affecting some users when downloading PDF documents using Chrome or Edge.
This issue has now been fixed, and downloads should work as expected.
Thank you for your patience while we worked to resolve this.
Issue
October 27, 2025 · 11:02 AM AEDT
Some users are currently experiencing issues downloading PDF documents when using Chrome or Edge. The browser may show an error such as “Couldn’t download - Network issue” or “Check internet connection.”
As a temporary workaround, you can select Print and choose Save as PDF to save a copy of the document.
Our team is investigating the issue and will provide an update once it has been resolved. Thank you for your patience.
← Back
Status